Investigating Card Declines
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 12:32 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2020 - 12:22 PDT
Investigating
Our team is investigating a higher than usual number of reports of cards declining when they shouldn't. We'll update here as we learn more.
Posted Jun 25, 2020 - 11:51 PDT
This incident affected: Features (Card Transactions).