Phone Support Unavailable
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Jun 04, 2020 - 09:09 PDT
Monitoring
A fix has been implemented and we'll be reopening our phone queue at 8:45am PT.
Posted Jun 04, 2020 - 08:38 PDT
Investigating
We are currently unable to receive phone calls. We’re investigating the root cause, and will update here once we have more information. For urgent issues, please send a support message via your Simple account or attempt your call at a future time.
Posted Jun 04, 2020 - 07:35 PDT
This incident affected: Features (Phone Support).