Photo check deposit issues
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Jul 27, 2020 - 09:25 PDT
Identified
The issue has been identified and our teams are actively working on restoring access to the mobile check deposit feature. If you're trying to deposit a check, but are running into an error, please try again later. As a reminder, our daily cut off for same day processing is 2pm PT (5pm ET).
Posted Jul 27, 2020 - 08:56 PDT
Investigating
Our team is looking into reports of not being able to submit mobile check deposits. We'll update here as we learn more.
Posted Jul 27, 2020 - 07:59 PDT
This incident affected: Features (Photo Check Deposit).