Check Deposits not posting
Incident Report for Simple
Resolved
This incident has been resolved.
Posted May 27, 2020 - 08:21 PDT
Monitoring
Check deposits from yesterday that were delayed have posted to customers' accounts. We're monitoring the situation and will update here as learn more.
Posted May 27, 2020 - 08:15 PDT
Identified
We've identified the root cause and expect the delayed check deposits to post to customers' accounts at around 8am PT.
Posted May 27, 2020 - 07:24 PDT
Investigating
We've investigating reports of some customers' check deposits from yesterday not posting to accounts. We'll update here as learn more and thank you for your patience.
Posted May 27, 2020 - 06:45 PDT
This incident affected: Features (Photo Check Deposit).