Photo check deposit issues
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 11:04 PDT
Investigating
Our team is looking into reports of not being able to submit mobile check deposits. We'll update here as we learn more.
Posted Apr 02, 2020 - 10:42 PDT
This incident affected: Features (Photo Check Deposit).