Missing Deposits
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 11:07 PDT
Investigating
Our team is looking into reports of some deposits (such as direct deposits) not posting to accounts this morning. We'll update here when we have more information and thank you for your patience.
Posted Jun 22, 2020 - 09:58 PDT
This incident affected: Features (ACH Transfers).