Longer than usual hold times
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 19:22 PDT
Monitoring
It's currently taking longer to reach one of our agents on the phone. We apologize for the delay and encourage you to use our Support articles or send us a support message if it's not urgent.
Posted Jun 25, 2020 - 13:03 PDT
This incident affected: Features (Phone Support).