Statements Not Loading
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 08:40 PDT
Identified
Our team has identified the root cause and will be pushing the fix to May's statements late tonight. If you need to download or access May's statement, please try tomorrow. Thanks for your patience.
Posted Jun 15, 2020 - 15:59 PDT
Update
Our teams are continuing to work to resolve the issue.

Note: This issue only affects May 2020's statements.
Posted Jun 15, 2020 - 09:45 PDT
Investigating
We're investigating reports of Statements not properly loading. We'll update here when we have more information and thank you for your patience.
Posted Jun 15, 2020 - 06:42 PDT
This incident affected: Features (Statements).