Photo check deposit issues
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Dec 28, 2020 - 09:48 PST
Investigating
Our team is looking into reports of not being able to submit mobile check deposits. We'll update here as we learn more.
Posted Dec 28, 2020 - 09:16 PST
This incident affected: Features (Photo Check Deposit).