Transaction Feed Delayed
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 08:23 PDT
Investigating
Our team is looking into reports of transaction activity not being updated. This is also affecting the ability to transfer to other Simple customers and from your Protected Goals account/Shared account. Thanks for your patience.
Posted Oct 15, 2020 - 07:48 PDT
This incident affected: Features (Instant Transfers).