Phone Support Unavailable
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 10:42 PDT
Investigating
We are currently unable to receive phone calls. We’re investigating the root cause, and will update here once we have more information. For urgent issues, please send a support message via your Simple account or attempt your call at a future time.
Posted Oct 19, 2020 - 09:50 PDT
This incident affected: Features (Phone Support).