Loans and CDs Unavailable
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Nov 12, 2020 - 09:21 PST
Monitoring
Things are improving and customers should be able to access their loan or create new CDs now. If you run into an error, please try again.
Posted Nov 09, 2020 - 13:57 PST
Investigating
Our team is looking into issues with loading and accessing Simple Loans and CDs. Thanks for your patience.
Posted Nov 09, 2020 - 12:07 PST
This incident affected: Features (CDs, Loans).