External Transfers Delayed
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 16:21 PDT
Identified
Our teams have identified the issue and we expect the transfers to post shortly.
Posted Jun 22, 2020 - 15:49 PDT
Investigating
Our team is looking into reports of external transfers that were scheduled to arrive today not posting yet. We'll update here when we have more information and thank you for your patience.
Posted Jun 22, 2020 - 14:08 PDT
This incident affected: Features (External Account Transfers).