Loans and CDs Unavailable
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Nov 06, 2020 - 16:09 PST
Investigating
Our team is looking into issues with loading and accessing Simple Loans and CDs. Thanks for your patience.
Posted Nov 06, 2020 - 09:28 PST
This incident affected: Features (CDs, Loans).