Investigating Errors
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Apr 15, 2020 - 07:42 PDT
Investigating
Our team is investigating errors when trying to Instant Transfer other Simple customers or between accounts, card actions, and activity feeds being delayed.
Posted Apr 15, 2020 - 07:15 PDT
This incident affected: Features (Instant Transfers, Balance & Activity, Goals & Expenses, CDs).