logo
Created with Sketch.
Simple.com
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
Phone Support Unavailable
Incident Report for
Simple
Resolved
This incident has been resolved.
Posted
Jan
06
,
2021
-
16:43
PST
Investigating
Simple’s phone lines are currently closed and will reopen on standard business hours at 7am PT tomorrow.
Posted
Jan
06
,
2021
-
13:42
PST
This incident affected: Features (Phone Systems).
×
Subscribe to Incident
Subscribe to updates for
Phone Support Unavailable
via . You'll receive .