Photo check deposit issues
Incident Report for Simple
Resolved
This incident has been resolved.
Posted Mar 23, 2021 - 07:56 PDT
Identified
The issue has been identified and a fix is being implemented. We will reach out via in-app messaging if there are any concerns with a deposit you submitted today.
Posted Mar 22, 2021 - 15:16 PDT
Investigating
Our team is looking into reports of not being able to submit mobile check deposits. We'll update here as we learn more.
Posted Mar 22, 2021 - 09:03 PDT
This incident affected: Features (Photo Check Deposit).